Blaxel

Unusual latency on previews creation
Resolved·Degraded performance

Following a surge in new users and usage for the past weeks, we have optimized our DB queries. There is more improvement planned in the future but the experience should already be improved now. This incident has been resolved, and service is operating normally again. Thanks for your patience.

Tue, Nov 18, 2025, 03:55 PM
(8 hours ago)
·
Affected components
Updates

Resolved

Following a surge in new users and usage for the past weeks, we have optimized our DB queries. There is more improvement planned in the future but the experience should already be improved now. This incident has been resolved, and service is operating normally again. Thanks for your patience.

Tue, Nov 18, 2025, 03:55 PM

Monitoring

A fix has been deployed, and we’re monitoring to confirm recovery. A small amount of residual impact may persist while systems stabilize.

Tue, Nov 18, 2025, 03:45 PM(10 minutes earlier)

Identified

We’ve identified the cause and are working on a fix. Some users may continue to experience degraded performance while we resolve the issue. We’ll share another update as soon as possible.

Tue, Nov 18, 2025, 01:01 PM(2 hours earlier)

Identified

We’ve identified the cause and are working on a fix. Some users may continue to experience degraded performance while we resolve the issue. We’ll share another update as soon as possible.

Tue, Nov 18, 2025, 10:26 AM(2 hours earlier)

Investigating

We’re investigating a service issue that may cause errors or slow performance for some users. Updates will be posted here as more information becomes available.

Tue, Nov 18, 2025, 07:20 AM(3 hours earlier)